Upgrade to 4.1 failed


We tried upgrading our application to version 4.1 of axon.
When we tried running the application we received an exception (stacktrace attached).

Digging a bit deeper we found that we got a ClassNotFoundException for the org.axonframework.axonserver.connector.command.AxonServerCommandBus
probably caused by the @ConditionalOnMissingBean on the commandBus Bean in AxonAutoConfiguration. (the AxonServerCommandBus is referenced here)

Currently we do not use AxonServer, so we excluded the axon-server-connector dependency. Including the dependency resolves the problem.

Are we supposed to include the axon-server-connector dependency on our classpath even when not using AxonServer or is unexpected behaviour?

Kind Regards,
Ben Allaerts

exception.log (5.75 KB)

BTW, I am on Ben’s team. This concerns an upgrade from axon 4.0.4 to axon 4.1.

Hi guys,

we’ve managed to reproduce this. We have recorded an issue in our issue tracker for this one:

We’ll get this fixed as soon as possible.

Hi Ben and Stijn,

As Allard pointed out, we have recorded the issue, and also resolved this last week (as can be seen here).
The fix is part of release 4.1.1 of the framework, which has been released the 26th of March.
Sorry to not update you guys earlier on this; I wasn’t aware there was a pending user group question.

My sincere apologies, and I hope everything will be resolved as soon as you update to 4.1.1!


Steven van Beelen

Axon Framework Lead Developer