while reading CommandBus concept through documents and source codes
for Axon version 2.o-snapshot, I felt that suffixing "Bus" after
"Command" is not a good idea .
A "bus" hits for a communication infrastructure which all bus
participating components can share , distribute data among of them
My understanding of intention of design "CommandBus" interface in
Axon is to match a Command to a corresponding CommandHandler.
Would it be nice to rename CommandBus to CommandRegistry?