No Handler for command: io.axoniq.demo.bikerental.bikerental.coreapi.RegisterBikeCommand


i want to test the BikerentalApplication from Allard Buijze (Github) and get this exception above.
Intellij, Ubuntu Server, Axon run as Docker. Container. AxonDashboard show the application as connected.

Best Regards

Hello and welcome Detlef,

I assume (based on the java package) the application you are talking about is bike-rental-demo.
If so, please note that it’s 2 years old and thus it may have some issues with recent Axon versions.
I haven’t tried that one myself yet but I noticed there is a bike-rental-extended which seems more recent. Have you tried this one?

In any case, when you get some errors it is best to

  • describe the steps you followed
  • describe the environment you have (OS, Java version, Axon version, …)
  • provide the relevant part of the log file (not just the error message)

Otherwise it’s really hard to guess what may have gone wrong.

Hi Milen,

thanks for yout answer. I try the extended version.