A couple of suggestions for minor enhancements to the DistributedCommandBus module.
- Extend JGroupsConnectorFactoryBean with a new field “channelName” which will be passed through to the JChannel.setChannelName method on creation. This allows more meaningful names to be used than those automatically generated by JGroups.
- Extend AnnotationRoutingStrategy to allow specifying the type(s) of Annotation that will be checked for, rather than hard wiring to TargetAggregateIdentifier. The use case is to support Command payload classes in POJO API JARs that otherwise have no need to reference Axon code. With this change they can declare their own Annotation types and remain isolated.
Let me know if you are interested, I can provide the pull requests.