Axon Framework - Release 4.5.1

I’d like to share that Axon Framework 4.5.1 has been released today.
Some of the adjustments we’ve done for 4.5.1 are the following:

  • Some internals have changed concerning command handling exceptions.
    Within a single JVM, Axon Framework knows whether the exception is transient or not.
    This piece of information allows the RetryScheduler to retry a non-transient exception since those are retryable.
    With the move towards distributed environments, the information whether an exception is transient was lost when we moved to the dedicated CommandHandlingException containing a details object.
    Pull request #1742 reintroduces this functionality in this release.

  • The new RevisionSnapshotFilter introduced in release 4.5 sneaked in a bug by not validating the aggregate type upon filtering.
    Pull request #1771 describes and solves the problem by introducing the aggregate type to the RevisionSnapshotFilter.

  • By enabling the CreationPolicy for the DisruptorCommandBus, a timing issue was introduced with handling events.
    Contributor “junkdog” marked the problem in issue #1778, after which pull request #1792 solved it.

  • Contributor “michaelbub” noted in issue #1786 that resetting a StreamingEventProcessor to a point in the future reacted differently when no token was stored yet.
    This followed from the implementation of the ReplayToken, which wrongfully assumed that if the given ‘token at reset’ was null, the start position should be null too.
    However, the start position might be the future, and hence it should be used in favor of null.
    This issue is addressed under this pull request.

For a detailed perspective on the release notes, please check this page.


The release is not available at Maven Central. Does it take that long to be published?

1 Like

Thanks for nudging us here Oliver. Normally it doesn’t take long, but I don’t see it on Maven Central either yet. It has been uploaded and Sonatype does point it’s present. I’ll investigate a little further to see if I can dig something up. Will keep you posted!

It looks like some artifacts made it while others didn’t: Maven Central Repository Search

Noticed. Opened an issue with Sonatype right now to ask what’s up. For those interested, you can spot it here.

The latest Spring Boot releases didn’t make it to the central repo, too.

So it seems to be a general problem.

I tried to build a project right now and it worked.
Seems like it just took some time for that to happen.

Under OSSRH-69262, Julian said the following:

We found an issue in our cache, we made a refresh for your groupId and missing files should work after a few hours, please let us know if you still have issues.

Indeed, their refresh solved the issue, as all dependencies can be retrieved right now.