Axon Dashboard Search not responding


We are investigating axon server at this moment. Everything works ok we can connect clients etc…The only thing is the Search (for events) in de Axon Dashboard is not responding (infinite turning wait icon)

We installed the axonserver.jar with a docker image to a linux (Redhat) server. Locally on docker for windows the same image is working ok.

Something to do with SSE axon is using in the response for the Search query ?


can you look in the Browser log and check if e.g. the network connection to Axon Server is being closed?


I see the network connection on ‘pending’ . No response visible, nothing in the console.

Seems a browser/network/firewall issue ?

I tried different browsers : chromium, chrome, opera, Firefox , IE ,but only Brave and curl seems to work on the query endpoint (we like to have it work at least with chrome though)
I played with ports, axonserver (host)names, docker hostname etc… , with no succes.

What’s also interesting , when in push the search button, nothing is shown, but right after i kill the axon server container (with docker rm -f) the events are shown !

Found it !! :
It is Sophos virus protection which got in the way. It has a feature called ‘web-protection’ which probably treats SSE repsonses as suspicous downloads and blocks them. Turning this of end it worked !